Errors While Restoring Backup Files
Symptom
Sometimes, when you try to open a Process file, error messages similar to the following are displayed:
FM:35 Process Runner
FM:38 SRP: 10 You can't open "<Process File Name>.itf" file because it has 0 byte length.
File may have become unstable/corrupted caused by network error during saving of file.
Please check your backup files (Documents\Innowera\Backup) to restore file.
A - 141: Process Runner
Error while opening "<Process File Name>.iff" file: Cannot find central directory
File may have become unstable/corrupted caused by network error during saving of file.
Please check your backup files (Documents\Innowera\Backup) to restore file.
Cause
This problem occurs due to the connectivity issue while saving the Process file.
Solution
To restore the Process files from backup
- Copy the backup file of the Process file from
My Documents\Innowera\Backup\<ProcessFileName>.bff
, paste it to your main working folder, and change its file extension from.bff
to.iff
. The backup files are automatically created atMy Documents\Innowera\Backup
ifthe option Updates/Backup under Tools > Options is enabled. This allows you to have a copy of previously working file. For information about the Updates/Backup option, see Updates/Backup. - If step 1 does not work, create a new Process file.
Similarly, if it is a transaction file, change the extension from .btf
to '.itf
, for GUI Scripting file change it from .bsf
to .isf
, and for Data Extractor file change it from .bte
to .ite
extension in the the main working folder.
For further assistance, please create a support case on Salesforce.