Process Runner Tab Unavailable in Excel

Symptom

The Process Runner tab is not available in the Microsoft Excel workbook.

Cause

Excel stopped responding due to some technical issue or the Add-in option was accidentally disabled by the user.

Solution

To resolve this issue, check the following possible solutions:

Option 1: Close All Excel Instances

To close all instances of Microsoft Excel

  1. Save and close all Excel instances.
  2. Open Task Manager and select Processes tab. If any Excel instance is running, select the Excel.exe, and select End Process.
  3. Open an Excel workbook and check for the Process Runner tab.

Option 2: Check for Process Runner Excel Add-in Under COM Add-ins

To check Process Runner Excel Add-in in COM Add-ins

  1. In Microsoft Excel, select FileOptions. The Excel Options window appears.
  2. In the categories pane, select Add-ins.
  3. In the details pane, select COM Add-ins in the Manage dropdown list and select Go.
  4. Ensure that Process Runner Excel Add-in checkbox is enabled in COM Add-ins list and the load behavior is set to Load at Startup.
  5. If Process Runner Excel Add-in is not displayed in the list, select Disabled Items in the Manage box and select Go.
  6. Select Process Runner Excel Add-in and Enable.
  7. If Process Runner Excel Add-in is displayed, but the load behavior is not set to Load at Startup, perform one of the following steps:
  8. Open an Excel workbook and check for the Process Runner tab.

Option 3: Check 'Excel Add-In' Settings in AutoFix tool

If the Excel Add-in tab was disabled using administrator rights, the AutoFix prompt might need administrator rights to utilize the AutoFix functionality.

Note: Close all the Excel instances before performing this step.

To check the Excel Add-In settings in AutoFix tool

  1. Go to Start > AutoFix Tool.
  2. Right-click, select Run as administrator. The AutoFix Tool [Administrator Mode] window is displayed.
  3. To check the load behavior, perform the following steps:
    1. Go to the Excel Add-in tab > Load Behaviour Setting section.
    2. If the load behavior for current user is disabled, select Auto FixYes > OK. You can also select Fix load behaviour of "Process Runner Excel Add-in" for all user to fix the load behavior for all existing users.
  4. To enable the add-in settings, perform the following steps:
    1. Go to the Excel Add-in tab > Disabled Add-in Setting section.
    2. If the Add-in Setting for current user is disabled, select Auto Fix link. The Add-in Setting is successfully enabled for current user.
  5. Open an Excel workbook and check for the Process Runner tab.

Option 4: Create Environment Variables

If the previous solutions do not work, debug VSTO (Visual Studio Tools for Office) Add-Ins using log files and alerts by creating environmental variables.

Ensure that Process Runner Excel Add-in is not listed under Disabled Items. This scenario occurs when Process Runner Excel Add-in causes a critical error in the Office application and is therefore marked as disabled. Office does not attempt to load Process Runner Excel Add-in from then on.

Note: If your Add-in is a Shared Add-In that does not use a COM Shim then you will need to check if mscoree.dll is listed in the Disabled Items list. If you find that your Add-In component is listed in the list, enable it and retry.

To add environment variables

  1. Open Control Panel and select SystemAdvanced system settings. System Properties window is displayed.
  2. On the Advanced tab, select Environmental Variables. The Environment Variables window is displayed.
  3. Select New in the user variables section. The New User Variable window is displayed.
  4. Create the following two environment variables:
  5. Select OK. The created variables are displayed in the list.
  6. Open an Excel workbook and check for the Process Runner tab.
  7. If you still see the error message, Could not load file or assembly 'Process Runner Excel Add-in, Version=4.30.124.50000, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Access is denied, check if you are using an anti-virus program, and ensure that you allow Process Runner Excel Add-in in the anti-virus security settings and retry to open Process Runner tab in Excel.

If the issue is still not resolved, run the latest updates for the anti-virus program and retry. If this also does not help, disable the anti-virus program completely and retry. Sometimes the anti-virus software also installs additional Office add-ins that you may have to disable by running through the anti-virus settings in the Control Panel. For more information about this issue, see https://blogs.msdn.microsoft.com/vsod/2008/04/22/troubleshooting-com-add-in-load-failures/.

For further assistance, please create a support case on Salesforce, and send a screenshot of the error message.

Related Topics: