'Connect to Message Server Failed' Error
Symptom
Sometimes, when you try to launch SAP GUI from Process Runner, an error similar to the following is displayed.
Connect to message server failed
Cause
This problem occurs because the path of the SAPUILandscape.xml file in the SAP system and Process Runner is not the same or due to the changes made in the System Connection Parameters setting.
Solution
To resolve this issue, check the following:
- Path of
SAPUILandscape.xmlfile - SAP system properties
To check the path of SAPUILandscape.xml file
- Open SAP Logon and perform the following steps:
- Select the hamburger menu icon available at the upper-left corner and select Options. The SAP GUI Options – SAP Logon window is displayed.
- Expand SAP Logon Options, and select Local Configuration Files. The path of
SAPUILandscape.xmlfile is displayed in the Loaded Local Files section.
- Open Process Runner and perform the following steps:
- On the Home tab, select SAP Shortcuts. The Magnitude Connector for SAP window is displayed.
- Select the Advanced tab. The path of
SAPUILandscape.xmlfile is displayed under the Local Config File section.
Ensure that the path of
SAPUILandscape.xmlfile in the SAP Logon and in Process Runner are the same. - Run the Process file.
To check SAP system properties, perform the following steps:
- Open SAP Logon, and perform the following:
- Select the SAP system in which you are facing the issue, and select Edit from the More drop-down list menu. The System Entry Properties window is displayed.
- On the Connection tab, select Group/Server Selection from the Connection Type dropdown list menu. If the Message Server has been changed in the SAP system properties, a message is displayed to indicate that the message server has been changed.
- Select OK. The Instance Number for the selected SAP system is updated.
- Open Process Runner, and perform the following:
- On the Home tab, select SAP Shortcuts. The Magnitude Connector for SAP window is displayed.
- On the Server/Group tab, select the SAP system and select Properties. The Properties<NameOfSAPSystem> window is displayed.
- On the Logon Values tab, select Auto Switch check box and change the logon method type. If Method 1 is selected, change it to Method 2 and if Method 2 is selected, change it to Method 1.
- Select OK.
- Run the Process file.
For further assistance, please create a support case on Salesforce.