SAP GUI Error During Recording

Symptom

Sometimes, when you record a Transaction Process file, the SAP GUI screen is displayed but when switching between two screens, the SAP GUI stops responding.

HT-ResolveSAPHanIssue1

Cause

This is a known issue of SAP GUI with some versions of SAP kernel.

Solution

To resolve this issue, perform the following:

  1. Download and implement the following SAP notes in your SAP system:
    • SAP Note: 1584498
    • SAP Note: 1659422
    • SAP Note: 1768010 (applying this note should resolve the issue)

    Note: If the above SAP notes are not relevant to SAP Kernel package levels, ensure that rdisp/check_master_slave_active parameter is 3.

    Ask your SAP Basis team to review and apply the above notes or make changes to the parameter. For further assistance, please create a support case on Salesforce.

  2. If you cannot apply the OSS Notes or your SAP Basis is in process of applying them, you may use few possible workarounds as described in this section.
    1. You can get SHDB access in SAP, use SHDB to record user actions in the SAP GUI for the transaction to create its recording and then import that recording in Process Runner. Please refer to point 2 under Suggested solutions in SAP GUI not Visible to know more on how to import the recording in Process Runner.
    2. Since this problem occurs only during recording and not while executing the scripts, you may use our ready-to-run cloud templates. You can download and change these templates to meet your requirements and use them in your system. You can even add your custom (z/y fields and screens) to these templates.
    3. If the above suggestions do not help then there are few more options to resolve the issue. For further assistance, please create a support case on Salesforce and we will create the template based on your requirement at our end.