Port already in use

Symptom

Sometimes, when a user tries to start the RLM server, the following error message is displayed.

portinuse

Cause

This issue occurs because another program or copy of RLM is already using the specified port, 5053.

Solution

Follow these options to start the RLM server:

  • Check with your IT department to ensure that no other program is using the port.
  • Reboot the server. If this is not possible, check if a duplicate instance of RLM is already running through Task Manager by displaying processes of all users.
  • If the issue persists, change the desired port. For information about how to change the port number, see Change Port Number of ISV Server.

Note: This issue can impact all the users connecting to RLM, as their local license files must be updated.