Communication error with license server (-17) & (-111)
Symptom
When a user tries to connect to the license server, the following error message is displayed.
SPRA:24 Communication error with license server (-17) Connection refused at server (-111)
Cause
This error occurs due to one of the following reasons:
- Innowera License Server is not installed.
- Not connected to the correct network; you are not on the same network where Innowera License Server is installed.
- IP Address/Host name mentioned in
PROR.LIC
file does not exist in your network. - Firewall is blocking the communication. Ensure that all the required ports are open. For more information about the required ports, see View Port Details of License Server .
- Your temporary license has expired. Check the expiration date.
Solution
Note: Ensure that Innowera License Server is installed on the computer. Check with your IT or network administrator.
To resolve this issue, perform the following steps:
- Select Start and go to Programs And Features in Control Panel.
- Click Turn Windows features on or off.
- Check Telnet Client and click OK.
- Open
C:\Users\Owner\Documents\Innowera\Lic
in your system. - Open
PROR.LIC
file in Notepad. - Copy the IP address and paste it in your web browser adding
5054
with colon:
in between. The License Server web interface is displayed. For example,192.168.100.163:5054
- Once the web page is open. Click Status in the pane on the left side and click the SHOW rlm Debug log option.
- Note down the port numbers you find in the web page.
- Open the Command Prompt window, enter
telnet
, followed by the IP address and port number, and press Enter.If the connection is successful, a blank screen is displayed with blinking cursor.
If you connection is not successful, an error message is displayed that indicates that the connection could not be opened.
Could not open communication to the host on port <PortNumber>: Connect failed
- You have to check the connectivity for both the ports mentioned in step 10. If any of the connection fails, communicate with your IT network team and ask them to open both the ports.
If the web page is not opened, ask your IT or network team to open the port number 5054
for the system with IP address found in PROR.LIC
.
Note: If you are using IE8 or higher, you might not be able to see right side of the website unless you turn on compatibility view. Check the Compatibility view of the web browser.
Now we know which two ports are required to be open, we are going to test them from Process Runner client computer using Telnet.
If both the connections are successful, and for further assistance, please create a support case on Salesforce.
If you have some other error, then refer to end user FAQ of the License Server: http://www.reprisesoftware.com/enduser_faq.htm