Resolve Settings/Authorization issue on Ehp4/Ehp5

Symptom

Sometimes, when you run a Transaction Process file, no message is returned from SAP to Excel.

Cause

This problem occurs due to one of the following reasons:

  • Change in SAP security and configurations
  • Upgrade or enhancement pack application by your SAP Basis team

Solution

To resolve this issue, perform the following:

Implement ABAP Add-on TX Package

The ABAP add-on TX Package includes multiple features like ‘SAP to Excel’ option or executing script in ‘Non-Batch Input mode’ or 'W-Suppress Field If Not Found In SAP' or 'X-Suppress Screen If Not Found In SAP' dynamic skip without any authorization changes. For further assistance, please create a support case on Salesforce.

Disable 'Force CTC' option

When no messages are returned from SAP in Excel Log column and if you find [CX] in Excel Log column header, perform the following:

  1. Click on ‘Logon Shortcut’ icon in the tool bar. Select SAP system and click on ‘Properties’ button.
  2. Disable ‘Force CTC’ option if it is enabled by default.
  3. Run the transaction again.

Check Authorization

If no messages are returned from SAP in your Excel message column, you may be missing the basic authorization. For more information about the authorization required, see Missing Authorization Error.

Turning on Batch Input Mode

When no messages are returned from SAP, please try to run the same transaction with Batch Input mode option ‘Enabled’ in Home tab. This might resolve your issue.

Error-troubleshooting-Settings-Authorization-issue-3

Disable SAP to Excel Option

When no messages are returned from SAP, the mapping type 'SAP to Excel' is used in Mapper.

Error-troubleshooting-Settings-Authorization-issue-4

We suggest you to try to run the same transaction with 'Suppress all copy from SAP to Excel mapping' option 'checked' in Home tab. This might resolve your issue.

Error-troubleshooting-Settings-Authorization-issue-5

SAP authorization error is encountered on running a Process file that was expected to return the document number. Check the logs displayed in the external Excel after the run and map the number from the message into a column. In the below screenshot 'AG' is the excel column in which logs are displayed.

When you run the Process file, a message is displayed in the log that indicates that a document with the <DocumentNumber> was created. You can map the DocumentNumber in column T instead of using SAP to Excel Mapping.

This can be done by changing the message settings in the Process file.

Error-troubleshooting-Settings-Authorization-issue-6

Check 'W-Suppress Field If Not Found In SAP' or 'X-Suppress Screen If Not Found In SAP' is used in Mapper

When no messages are returned from SAP, then check whether the dynamic skip 'W-Suppress Field If Not Found In SAP or X-Suppress Screen If Not Found In SAP ' is used in Mapper.

X_W_Dynamic_Skip
  • W-Suppress Field If Not Found In SAP: This functionality is used to suppress the field during the transaction execution. Here, field gets validated in the SAP and if it is not found in SAP then field automatically gets suppressed. Using this functionality, user can upload the data without receiving any field missing error.
  • X-Suppress Screen If Not Found In SAP: This functionality is used to suppress the screen during the transaction execution. Here, screen get validated in the SAP and if it not found then it automatically gets suppressed. Using this functionality, user can upload the data without receiving any screen missing error.

If the above mentioned functionality is in use, then ensure that a special authorization like S_DEVELOP is added to the SAP profile of the user or the ABAP Add-on TX Package is installed in SAP Landscape.

Other Options

To download the field contents from SAP, use Data Extractor or BAPI for extracting the required value. For example, if you want to download the document number then download it from SAP BSEG table and assign it to the required column by assigning appropriate filters. This can be done in connected Process files that involves running a Process file one after another. For more information, see Process Connection.

If the above suggestions do not help then there are few more options to resolve the issue. For further assistance, please create a support case on Salesforce.