'Interface not Registered' Error

Symptom

When you open a Process file and select the Excel icon to use the external Excel file as a source, the window to browse the Excel file may not be displayed. Instead, error messages similar to one of the following are displayed:

FM:50 Process Runner

FM:52 Microsoft.Interop.Excel

FM:50 Process Runner (TYPE_E_CANTLOADLIBRARY)

Cause

This problem occurs due to the leftover registry key if you have upgraded or downgraded your version of Microsoft Office.

Solution

To resolve this issue, perform the following steps:

  • Enable the Launch external Excel natively on Excel icon option in Process Runner
  • Repair Microsoft Office installed on your computer

To enable Launch external Excel natively on Excel icon

  1. Open Process Runner.
  2. On the TOOLS tab, select Options. The Options window is displayed.
  3. On the Excel tab, select Launch external Excel natively on Excel icon. The Shell command is used to launch the Excel file, when you select the Excel icon in the HOME tab to browse the external Excel file.
  4. Select Auto. Detect > Apply > OK.

Note: Close all the instances of Excel and Process Runner before you reopen the Process file.

The steps to repair Microsoft Office vary depending on your Windows operating system. For more information about how to repair Microsoft Office, see Microsoft documentation.

For further assistance, please create a support case on Salesforce.