Bad hostname in license file or port@host (-43)

Symptom

When the client is unable to communicate with the License Server, the following error message is displayed in the License Check window.

Bad hostname in license file or port@host (-43)

Bad hostname for network connect (-131)

Cause

This error may occur when the host name in the PROR.lic file is not valid or if the Innowera License Server is not installed.

Solution

Follow these steps:

  1. Ensure that the Innowera License Server is installed.
  2. Create a new PROR.lic file for the clients to connect to License Server from their computers. To create the license file, perform the following steps:
    1. Note the IP Address or the name of the computer where the License Server is running.
    2. Open Notepad and enter SERVER <IPAddress> ANY <PortNumber> where IPAddress is the IP address and <PortNumber is the port number assigned to the Innowera License server.
    3. Save this file on the desktop with the name PROR.lic.
  3. Copy this file to My Documents\Innowera\LIC and start Process Runner. The connection to the License Server is established without errors.

    Note: Ensure that you are on the same network where the License Server is installed. If you are connected via VPN, check the connectivity properly.

For further assistance, please create a support case on Salesforce.